7.4

pretty bad
Typical Repair Cost:
No data
Average Mileage:
13,550 miles
Total Complaints:
7 complaints

Most common solutions:

  1. not sure (5 reports)
  2. hard reboot (1 reports)
  3. new module (1 reports)
Get notified about new defects, investigations, recalls & lawsuits for the 2013 Ford Escape:

Unsubscribe any time. We don't sell/share your email.

Get free help with your lemon!
close ad

This problem may be covered under warranty. Ask your Ford dealer.

problem #7

Apr 202016

Escape SEL V6

  • Automatic transmission
  • 35,000 miles

The whole MFT display shut down. It killed the climate, sounds, telephone, and navigation. Second time it has done this. First time it came back on its own. This time no.

- Rusty P., McGregor, TX, US

problem #6

Aug 252014

Escape SEL

  • Automatic transmission
  • 18,980 miles

THE ENTIRE CENTER CONSOLE WENT DOWN AND OUT. NO RADIO, NO SYNC, NO NAVIGATION, NO CLOCK. IT EVEN MELTED THE END OF MY PHONE CHARGER THAT PLUGS INTO THE CENTER CONSOLE UNDER THE ARM REST.

- awolfrum, Clarkston, MI, US

problem #5

Aug 012013

Escape SEL 3.2L

  • Automatic transmission
  • 13,000 miles

The navigation is an ongoing problem. It stalls for navigational routes sometimes taking up to 5 minutes to load at times. Sometimes it doesn't load until I have already had to use a back up phone navigation and already made it to my destination. Hard reboot done at Ford. It appeared to have fixed the problem.

- escape13, Fort Myers, FL, US

problem #4

Feb 102014

Escape SEL 3.2L

  • Automatic transmission
  • 24,000 miles

Power to Navigation screen, clock, radio, etc. Cuts off at least 6-8 times a day! So if you are on the phone.... good bye caller! If you are in route to destination.... good bye destination... It you are looking for a time... goodluck being ontime because the GPS never reboots with the right time!!!! OH and the best is NO back up camera when this happens, which means no sensors are working outside the car to notify you of hitting anything. I am taking in for service to indentify problem.

- escape13, Fort Myers, FL, US

problem #3

Jun 242013

Escape Titanium 2.0L Ecoboost

  • Automatic transmission
  • 1,607 miles

My 2013 escape navigation msystem shows inaccurate mph info on the screen when traveling on a freeway in New Mexico, the posted mph is 75 mph when our navigation screen changes from 65 mph to 75mph it shows the speed limit as 74mph. I don't know about the rest of the U.S. but New Mexico only has speed limits posted in ZEROS or FIVES. Ford cannot fix my problem at this time, they say they don't know what to do. Evidently the new 14's work properly if this is the case then they should be able to fix my 13.

Very Frustrated

- Thomas C., Albuquerque, NM, US

problem #2

Sep 302012

Escape SE 4wheel Drive 2

  • Automatic transmission
  • 60 miles

I have been on the phone with Ford direct about this Navigation problem, and they just keep telling me to TAKE IT TO A FORD DEALER, OF WHICH I AM TOLD THERE IS NO FIX FOR THIS PROBLEM !

I am sure there are others with this problem, it just does not communicate to GPS for some time 20 miles, or 30 minutes.

- John H., Albrightsville, PA, US

problem #1

Oct 142012

Escape Titanium 2L Turbo

  • Automatic transmission
  • 1,950 miles

The Nav. System has been having ongoing problems since new - 2mo. ago. The display [at times] shows some 6 blocks off of actual location, goes black, resets clock and goes in "Vehicle Transit Mode" which disables some features. This requires a trip to the Dealer to fix/reset the system. The car has been in 3 times for this issue as well as other ones covered in another complaint.

- grantg, St Petersburg, FL, US