6.4

fairly significant
Typical Repair Cost:
$200
Average Mileage:
77,050 miles
Total Complaints:
5 complaints

Most common solutions:

  1. not sure (4 reports)
  2. replace iac valve (1 reports)
Get notified about new defects, investigations, recalls & lawsuits for the 2003 Ford Explorer:

Unsubscribe any time. We don't sell/share your email.

problem #5

Dec 122014

Explorer Eddie Bauer 4.6L V8

  • Automatic transmission
  • 76,000 miles

Every time I stopped on a stop sign or red light the car would sputter and idle roughly. Rev will spike over 3K revolutions. Sometimes the engine would stop completely and had to restart the car again. Also gasoline consumption was getting worse. Tried several IAC from a car parts chain store but were really bad quality. The fourth time I was fed up and bought the valve from the car dealership for a few bucks more but were worth it. After that it had been running smoothly.

- A K., Calexico, CA, USA

problem #4

Feb 092011

Explorer V6

  • Automatic transmission
  • 88,000 miles

Bucking occurs on and off. Especially when you slow down and then try to speed up. NEED SOLUTION!!!

- Kelly S., Wilmington, DE, USA

problem #3

May 252010

Explorer Eddie Bauer 4.6L V8

  • Automatic transmission
  • 70,000 miles

How can I fix it if I can't find anyone who can tell me what's wrong with it.

GARBAGE.....This thing is becoming a royal pain in my buttocks. I am about to burn this thing to the ground...

JUST SAY NO!!!!

- dager, Cottage Grove, WI, USA

problem #2

Feb 052008

Explorer LX 4.0L Flex Fuel

  • Automatic transmission
  • 115,100 miles

I have a 2003 ford explorer and Has a Flex fuel system 4.0L At times not all the time once in awhile I will be going down the road in town and the engine will idle up and down, I think this has something to do with the computer or a sensor for witch the RPM's go nuts Any idea what this could be? It will only do this once in a great while So if it does this again I then take it to a shop they never find a damn thing wrong with it, Does the computer keep track of what is going on if I do take this in ASAP..?

- Dj M., Viroqua, WI, USA

problem #1

May 152007

(reported on)

Explorer XLT 4.0L V6

  • Automatic transmission
  • 36,000 miles

The Explorer started running rough, would shudder, and eventually turned on the "Service Engine Soon" light. I checked codes and it showed that the engine had a misfire on cylinder #3 as well as a low rpm misfire. Took it to the dealer (Yucca Valley Ford) they charged me for the diagnostic fee and changed the spark pugs (not under warranty). Fast forward 3 months, it begins again, so I pay for new spark plugs again. The service manager I deal with is a great guy, but there seems to be lacking some expertise out on the shop floor. No change, last time I took the vehicle in, they saw that it had stored a code, but couldn't get the problem to present itself. Still No Change. It is finally due for its 45k service and the problem still exists.

Update from Jan 18, 2010: I took the vehicle back to the dealer with the same problem. Here is the list of what they changed. 1. New Plugs (again). 2. New Coil Pack (apparently this will go bad with multiple misfires) 3. New ECU (reflashed with the latest firmware)

After all this was replaced... the problem still existed. So they called Ford HQ. Apparently when they checked the plug wires, they didn't check them correctly.

So after they paid for my rental car, and replaced a lot of expensive parts. It was a bad plug wire. The service manager tells me not to worry about it, they won't charge me for the parts! I simply say thanks. Not wanting to pursue this any farther.

The key from what I understand, is that like on older cars, when you change the plugs, change the plug wires as well, failure to do both could lead to the coil pack to fail.

- Jeffrey F., Twentynine Palms, CA, USA