10.0

really awful
Typical Repair Cost:
No data
Average Mileage:
87,350 miles
Total Complaints:
3 complaints

Most common solutions:

  1. complete block replacement (2 reports)
  2. not sure (1 reports)
Get notified about new defects, investigations, recalls & lawsuits for the 2008 Hummer H3:

Unsubscribe any time. We don't sell/share your email.

problem #3

Mar 292018

H3 Inline6 3.2L

  • Automatic transmission
  • 89,000 miles

March 29, 2018 on the interstate and lost power. Had tow truck take Hummer to Luther Family GMC in Fargo. They tell me $8,500 for a new motor. I tell them to fix it, there's nothing else I can do. I just bought it a year ago from Corwin in Fargo ND. I still owe $15K on it, so I feel like I HAVE to fix it.

I emailed GM several times and they tell me there's noting they can do. They say Luther will give me a rental for $15.00 a day. That by now would be over $900.00. 2 weeks before engine went out I have the thermostat and the actuator cleaned for $650.00 now another $8500 for GM. I have asked them for help because they know this is a common problem and they threw me to the dogs. They tell me they were going to have my engine expedited and that was 3 weeks ago, still have not seen it so they lied to me about that also. Never again GM...thanks for nothing and putting my family through hell.

- Lyla S., West Fargo, ND, US

problem #2

Sep 012016

H3 Luxury

  • Automatic transmission
  • 74,000 miles

Now I'm looking at a $3500 cost of breaking the engine down, because it now needs a new bottom block. This does not include the $7000 cost of engine if needed, and the $4000 cost of labor. If this repair is not covered under the extended warranty for MAXCARE, then I'm TRULY F*CKED!!!! all of the above costs were MY out of pocket expenses... the rest which have already totaled well over $10/k have been covered. Depending on what the warranty folks say, I may be out of $3500... I know they don't like to cover things, but this is a total GM defunct vehicle. I've got 30/k miles and still another year left on the warranty and I plan to use it until it's done. I just hope they figure out this issue and it's covered.

- xatikinx, Kapolei, HI, US

problem #1

Nov 172015

H3

  • Automatic transmission
  • 99,000 miles

I was on the freeway and car started shaking and then could not drive over 15 miles per hour. While I had it on Drive and took my foot off the accelerator, the car would jump foward a few times. I then put it on park and accellerated and it sounded fine but as soon as took my foot off the accelerator, it started shaking again. It was shaking uncontrollably. pulled over and got my mechanic on the phone. I told him engine light was on and so was the TCS icon. There was a message saying "Service Stab Sys" My mechanic said he thought it had something to do with the "throttle." He told me to shut the engine and turn it back on because it would reset itself. I tried 3-4 times while I had him on the phone. He then told me to take the key out and try turning the car on again. It then worked okay enough to get off the freeway. I let it cool down then drove it home. I also noticed that when I would go over a bump on the road it felt like it would lose power like it wasn't connecting (missing) or not getting enough gas so I would take my foot off the accellerator. The engine light is still on and taking it to the dealer in the morning.

- Graciela G., Chino, CA, USA