7.9

pretty bad
Typical Repair Cost:
No data
Average Mileage:
19,750 miles
Total Complaints:
14 complaints

Most common solutions:

  1. not sure (9 reports)
  2. software update (5 reports)
Get notified about new defects, investigations, recalls & lawsuits for the 2016 Jeep Cherokee:

Unsubscribe any time. We don't sell/share your email.

Get free help with your lemon!
close ad

This problem may be covered under warranty. Ask your Jeep dealer.

problem #14

Jun 092019

Cherokee Latitude 3.2L

  • Automatic transmission
  • 38,000 miles

I just bought my 2016 Jeep Cherokee Latitude. I did love it until yesterday. I have only had it 10 days and I was over 140 miles from my house. The engine light came on and then the Service Transmission message came on. That is where it all started going wrong. I couldn't drive over 40 miles an hour. If had to come to complete stop, it took it forever to start going again. Not a good situation to be in when sitting in traffic or trying to turn across oncoming traffic. This is a total nightmare for me. I am thankful I was by myself and didn't have my grandchildren in the car with me. Chrysler, you should be ashamed of yourself for not fixing this issue permanently, as I am understanding updating the software is just a temporary fix. I will tell you that if it happens again and anything happens to me, my family has been instructed to sue, as I can't afford to get another vehicle. My life is in your hands!!!

- Tonya L., Lockhart, TX, US

problem #13

Nov 102018

Cherokee Latitude

  • Automatic transmission
  • 26,382 miles

It was very worrisome because when we called and made the app to fix it my husband asked if we could drive it and they said not very far. We were nervous about driving it because it happened twice before we got it fixed.Thank you for this service.

- Sandra B., Warsaw, US

problem #12

Oct 282018

Cherokee Latitiude

  • Automatic transmission
  • 47,000 miles

You can't drive it! No power. Won't go. Car cannot be used.

- Doug P., Fort Worth, TX, US

problem #11

Jul 092018

Cherokee Latitude 2.4L

  • Automatic transmission
  • 62,000 miles

A few days ago I was driving on a city highway at approximately 60mph when all of a sudden my vehicle started to decelerate. Even when pushing the gas pedal there was no acceleration. The service transmission message popped up on the dash and the engine light came on. Luckily I was able to make it over to the shoulder lane safely. I turned the ignition off for a short period of time and then restarted. The service transmission message was gone but the engine light stayed on. I was able to drive but could not accelerate past 45mph.

I took it to Autozone to have it scanned and see what codes were triggering the engine light. I was told that it was code P0887 which is an issue with the TCM. Upon research I learned of the recall on the 2014-2015 models and the issues with the 9 gear transmission that is also now in my 2016 model. The same thing happened again on my way home from work and i am worried that the trans is bad and the amount of money it will cost to repair because my warranty ended 2,000 miles ago!

I don't understand how I already have transmission issues at 62,000 miles! Obviously there is a problem with this 9 gear transmission! If I would have known about the issues with this trans in the previous models I would have NEVER purchased the 2016 with the same trans!

- mickeyjj12, Clarendon Hills, US

problem #10

Jun 302018

Cherokee 3.2L

  • Automatic transmission
  • 8,863 miles

109 degree day, driving in desert when dash lights up and buzzer started - I was so blessed to have clearance to change lanes, exit off 347, turn around and limp back to town. It took 90 minutes for a tow and he took car to dealership in Tempe. Persisted in calls to dealership to no avail. left message, no response. After getting rental car, drove there Sunday to verify they had car. They did flash TCM and PCM on Monday, called to say fixed. This is our 4th Jeep and they were all extremely reliable, bought and had service at this same dealership but customer service was unacceptable this go round.

- Jenny K., Maricopa, AZ, US

problem #9

Nov 252017

Cherokee Sport 2.4L

  • Automatic transmission
  • 5,645 miles

Driving on hwy 11/25/17 and check engine light and service transmission msg came on. Transmission did not function properly and caused car to be stuck in one gear. Went into limp mode and made it to destination. When car was at a stop it was hard to accelerate because it was stuck in a higher gear. We turned it off and put it in park, when it was restarted it seemed to reset but the check engine light was still on. Recurred again on the way home as well as on 11/26/17.

Brought car into Chrysler dealer on 11/28/17. Rode with technician and problem was duplicated. Once car hits 8th gear all warnings return. Diagnostic test gave code for TCM power control circuit high,vehicle was flash reprogrammed and I was advised that it should resolve the issue. This was most recent software update which came on 4/4/17.

After a test drive issue currently seems resolved. Reporting it because it is a major safety defect and want it known that newer models are still having issues with the 9 speed transmissions. When this occurs it makes it very unsafe to drive on highway.

- Alice R., Savannah, US

problem #8

Jun 302017

Cherokee 2.4L

  • Automatic transmission
  • 13,634 miles

June 30, 2016 on the highway, bumper to bumper traffic pouring down rain and service transmission message came on, engine light came on, and had absolutely no acceleration capability. Managed to stay with traffic and proceed to the off ramp to a gas station. called the Jeep phone number provided by UConnect explained to them my issue I have been having with my Jeep. Needless to say I was disconnected twice by them. My vehicle has less than 14,000 miles on it and they can't seem to find the issue. NOT HAPPY! Finally arrive to our destination where the vehicle sat for the night and it seemed to magically fix the problem. Well, now July 6, 2017 traveling again on the highway and the service transmission message came on, engine light came on, and lost acceleration capability again. Pulled off the highway and happened to run into a Chrysler Truck mechanic that asked what was going on. He took a look and said that it looked to be an overheating problem but didn't have his diagnosis kit to say exactly and said good luck. (he also mentioned since FIAT took over he has not been happy being their motors are JUNK! NOTHING BUT PROBLEMS!! Made it to an auto parts place and ran a diagnosis on it, came up with this code: P0887 - TCM Power Relay Control Circuit High. Definition: indicates that the TCM Power Relay Control electrical circuit signal had high voltage for a predetermined period of time.

Tomorrow it will be back to the dealership service station!! solution TBA

- Tommi N., Lansing, MI, US

problem #7

Jun 012017

Cherokee Trail Hawk V6

  • Automatic transmission
  • 14,913 miles

Bought my Trail Hawk used with only 18,000 k on it. Thought it was a great deal. Noticed right away that the transmission jerked especially when in low gears. Then one day the service transmission light came on and the engine light. The car lost power and felt like it was in neutral. I was on the highway in the fast lane and the vehicle slowed down to a dangerous speed. I came up to my left hand turn into work. I had to wait for oncoming traffic to pass but when I saw an opportunity to turn the engine sounded like it was revving but was not moving very fast. Was scary and dangerous because there was more highway traffic coming. Finally got through the turn. Parked and turned off car. When I started it again the service transmission light was out but the engine light was still on. Took it to my dealer and was told I probably needed software upgrade. Seemed to fix the problem for about 3 days. Service light came on again. Lost power. I pulled over and put the vehicle in to park then the light went out. Was able to resume driving safely but scared. Happened to more times so took it back to the dealership. Told it needed a new transmission module. Told me it was fixed and asked if I wanted it washed. Said yes. When they went to put it back in the wash bay it would not move, was stuck in nuetral again. They had to push it back into the bay. Told now that they don't know what is wrong with it and gave me a loaner. Said I might need a new transmission. This really sucks. Almost think I bought a Ford. Very disappointing Chrysler. Wished I would have done more research before I bought. Was told by others that once they replace the transmission your vehicle will never be the same again or how it was to be in the first place. Any feedback on resolution to this problem would be great.

- Shellly J., Nanaimo, BC, Canada

problem #6

May 222017

Cherokee Limited 3.2L V6

  • Automatic transmission
  • 19,100 miles

My 2016 Jeep Cherokee started having issues on my way home from work yesterday, the service transmission message popped up on my display and the engine light came on. The service transmission was on for approximately 5 minutes, and during this time it felt like the car wouldn't accelerate. After the service message went off, it drove normal, but the engine light remained on.

Was able to drive it to the Jeep dealership this morning, but they couldn't see me and had to make an appointment for Thursday. I asked if it was safe to drive, the technician said yes, as long as the engine light didn't start flashing and I didn't have any further acceleration issues. On my way back home, the service transmission message was back, and had acceleration issues. The message went away a few minutes later and all was fine, except the engine light was still on from yesterday.

I'll report back once I return from the dealership Thursday.

Update from May 25, 2017: Update: Per the Jeep dealership, it needed a transmission software update. So far so good.

- Philip M., Dale City, US

problem #5

Feb 102017

Cherokee

  • Automatic transmission
  • 5,300 miles

My 2016 Jeep Cherokee only has 5300 miles on it. It gets serviced on time and I drive it mainly on the weekend (and short distances). I was driving home one evening when the "Service Transmission" light came on. The odometer stopped working and the car didn't seem to be working correctly. When I stopped at a light to turn left, the car revved, but moved very slowly (almost as if it was going to stall). Luckily, there weren't any oncoming cars in the opposite lane as I slowly crossed the intersection. Had there been any oncoming cars, we would have been likely been in an accident. Fortunately, I was very close to home and was able to have my car towed the next day to the service station.

Apparently the issue was due to the car needing a software update and it was able to be fixed. However, I am still concerned that this problem could reoccur since there's no notification in the car to indicate when my car needs a software update. I expressed this concern to FCA, but received the rote response that this issue is routine (just like an oil change). It's pointless to go back and forth with Chrysler because they aren't acknowledging responsibility for this issue.

This is more than just a simple "oil change" fix. This is a serious issue that can affect the overall safety of the vehicle and it doesn't seem like FCA is doing anything to really address this concern (such as providing automatic software updates in the vehicle). I guess I just have to keep my fingers crossed that this issue doesn't occur again. And let's hope I don't get in to an accident.

- lwitthohn, Windermere, US

problem #4

Oct 262016

Cherokee Latitude 3.2L V6

  • Automatic transmission
  • 12,953 miles

On October 26, coming back from Texas, I got a service transmission on the display. I was 22 miles from my house but only 10 miles from the dealership I purchased the car from. They did a software update and it seem find. On October 27, I was driving to Michigan due to death in my family. I got as far as Joplin, MO and the service transmission light came on again. I phone the dealership that I purchased the car from and they gave me a Jeep dealership in Joplin, MO and I took my car to them and I still don't have my car. I was given a rental to continue my trip but I am back in Oklahoma City and I still don't have my car and don't know when I will get it back. I called the dealership in Joplin, MO to get a status on my car. I have not looked at the car to see what is needed to fix problem.

- ruthiej, Oklahoma City, OK, US

problem #3

Oct 142016

Cherokee North

  • Automatic transmission
  • 2,769 miles

I am not much of a complainer, I would rather sell the car than put up with any further BS but that would be putting the problem on someone else. I drove the car to work one day and pulled into the garage. Just as I was searching for a spot to park the car would not move, I was baffled I couldn't figure what to do. I put it in reverse, it clunked so bad I thought I broke something, I put in neutral it would clunk I put it drive it would clunk it wouldn't go anywhere. I sat there dumbfounded until i put it in neutral and it rolled forward and i pulled into a spot a left it, absolutely flabbergasted.

I proceeded to make calls trying to get help, that was like pulling teeth. I got a number for road side service and got them to take the car to a dealership. They told me they would put it on the scope, it took them 4 days to get the car back to me. They told me it was an update failure for the transmission. Four days for them to tell me this...I feel so badly abused by the way I was treated that I just want to sell the car....

- elaineab, Calgary, AB, Canada

problem #2

Oct 232016

Cherokee Sport

  • Automatic transmission
  • 12,473 miles

The service light came on to service the transmission as I was driving. I immediately checked the transmission temperature gauge and it read 154 degrees the car then suddenly shutdown. I had to coast to the side. It acted as though it had shifted into neutral but it still showed in drive. It was very scary and very dangerous.

- Deborah G., Napa, CA, US

problem #1

Jul 082016

Cherokee Latitude 3.2L V6

  • Automatic transmission
  • 7,133 miles

On Friday 07/08/16 I was driving home from work when I went to pass a car on a two lane road. I stepped on the gas and the engine revved to a high RPM but NEVER sped up. The engine light came on and a message came up saying "service transmission". I drove it home (about 45 miles) and the transmission never shifted out of 4th gear. When I got home I tried to go up my driveway (about 100 yards) and the Jeep would hardly move. I put it reverse and it worked fine. I did this three times and each time in drive it would barely move! The dealer I got it from, Lander's in Benton, Arkansas, seemed to care less! I called assist on Tuesday 07/12/16 and they had it towed to a dealer 20 miles away. That Dealer, Paul Miller in Melbourne, Arkansas, basically said they would get to it when they get to it because they were "busy". I bought this Jeep on 03/17/2016 and it has 7133 miles on it! I think it should last longer than that. Luckily I have a 19998 Dodge pickup that works fine as they did not give me a rental vehicle. I still have not heard a word from Paul Miller Jeep. I feel that this 9 speed transmission should be under recall as it is a piece of JUNK ! I would not recommend this vehicle to anyone. This is the first automatic transmission I have bought since 1972 ( I have had manual transmissions since then ) and I am sorry that I bought this vehicle ! I hope this help's others so they do not make the same mistake that I made !!

Update from Jul 29, 2016: The dealer had it for a week ( with no rental provided) I have put on 400 miles and the transmission seems to be OK so far. Now I have a clicking in the gear shift that I did not have before.

Update from Dec 16, 2016: 12/15/2016

Well it happened again. I now have 15115 miles on this Jeep. After work I got in it and put it in reverse AND NOTHING HAPPENED ! I had to shift from park to reverse 3 or 4 times before the transmission finally went into reverse. I backed up and then put it in drive and nothing happened for 3 or 4 seconds. Then it finally kicked into drive. The check engine light and the traction control light came on. I had it towed again to the dealer today ( 12/16/2016 ) to get it fixed. Who knows how long I will be without it again. I called Jeep to set up to get a rental car and they said that I would have to pay for it and then I would have to send in the invoice to get reimbursed for the cost of the rental ! I also had the ignition switch module short out on this vehicle. That part has been on back order since 10- 28- 2016

I have also had problems with the media player voice commands and the radio.

PLEASE DO NOT BUY ONE OF THESE VEHICLES AS THEY ARE A TOTAL PIECE OF JUNK !!

- Dan B., Ash Flat, AR, US