6.0

fairly significant
Typical Repair Cost:
No data
Average Mileage:
47,100 miles
Total Complaints:
5 complaints

Most common solutions:

  1. not sure (5 reports)
Get notified about new defects, investigations, recalls & lawsuits for the 2014 Chevrolet Camaro:

Unsubscribe any time. We don't sell/share your email.

This problem may be covered under warranty. Ask your Chevrolet dealer.

problem #5

Feb 012021

Camaro LS v6

  • Automatic transmission
  • 45,000 miles

I bought a used 2014 Camaro. Initially no problems but in the last month the radio has been cutting out and the signals do not work when this happens. Usually it takes about 5 min for them to start making noise again. Sometimes when I turn the signals, the radio literally comes on and you hear radio white noise instead of turning. I called Chevy dealer to verify if there was a recall but they only told me they would do a diagnostic for the problem. Since then I have not been able to use my radio and my signals sometimes work, other times it cuts out. It's distracting and I'm quite upset as I do like the car and I only have 55,000 miles on it.

- Yanira D., Tempe, US

problem #4

Jan 022019

Camaro LS 3.2L V6

  • Automatic transmission
  • 78,000 miles

I started having problems with my radio about a year ago, around August 2018, but it was just randomly cutting off. Then around November 2018 it started cutting out more often and when I would use the blinkers the radio would completely turn off or it would make this high pitched static noise that I couldn't turn off without turning my car off. January 2019 my radio turned off and hasn't been back on since. I have no sound at all inside my car. When the blinker is on, no sound. When I get in and don't put my seat belt on, no sound.

- Kristen B., Texarkana, TX, US

problem #3

Jul 192018

Camaro

  • Manual transmission
  • 61,590 miles

Electrical problem started with the driver door window. It kept going up then down multiple times by itself (happens sporadically). Then quickly progressed (a couple of weeks later) to include the radio. While driving my stereo system cut out it had the settings emblem on the display screen and would not reset. Had to pull the car over, shut it off, and then restart the vehicle.

Then while using the blue tooth for my cell phone through my car's audio system, a loud pop sounded and the whole display flashed on and off. Ended the phone call, and was sitting outside of work just trying to listen to the radio and the entire system kept cutting off. I shut the car off 5 times in 15 minutes (literally). Now I'm getting ready to go home after working all day and not sure what my car is going to do. I've had other issues with this car well. 1 With my a/c the dealer wanted to charge me over $800.00 to fix saying it was my heater core leaking and that they would cover all the expenses to repair but that the windshield needed to be removed and that my warranty would not cover it, when in fact I previously took my car to 3 different mechanic friends and they all said it was my compressor blowing the fuse. My extended warranty kicked in and I had Pep Boys fix it over the dealership due to their shenanigans. 2 My clutch pedal got stuck and I couldn't get my car to move. Thankfully there was a spring that was stuck at the bottom of the pedal I was able to tap on and my pedal released. Then there is also the fact that my car was only 2 months old and I had to had the seals on my transmission replaced. My car wouldn't go into reverse (I've been driving manual transmissions for over 20 yrs and never had this happen to me. I've replace 1 clutch in a 2001 Kia Sportage with 189,000 miles on it at the time.

Anyway.... Hopefully we can get enough complaints to get a recall for these problems because I absolutely love my car.... I'm a single mother and still paying for my car as well. I cannot afford these repairs...

- Jannette T., Silver Springs, US

problem #2

Mar 182018

Camaro 2LS 3.6L ZV6

  • Automatic transmission
  • 49,000 miles

When hitting the brake, using the blinker, high beams, or turning on the back window defroster; the radio shuts off with a pop, the A/C will flicker, speakers are static. The right parking light doesn't stay illuminated at night but blinker works. I bought this brand new in 2014 and I'm the only owner, this shouldn't be happening. This problem should maybe occurring on older models, not 4 year old cars.

- Matt C., Jenks, OK, US

problem #1

Nov 072014

Camaro 2lt Convertible

  • Automatic transmission
  • 1,850 miles

Battery dead. Recharged by dealer and no problem found. Pick the car up and heated seats and "my link" display goes in and out. Bring back to the dealer - "reboot" the master computer. Bluetooth now doesn't work and when I backed out of the driveway the reverse camera stayed on for miles.... before the mylink rebooted of course. Every time.. no problem found???? Electrical or computer problem -not sure. Concerned about safety and reliability is zero right now.

- valkuhn00, Stratford, CT, US